summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Rheinsberg2024-01-10 12:49:01 +0100
committerDavid Rheinsberg2024-01-10 12:49:01 +0100
commitdcd1ea694486ec3daf994785fbfc71b02874d67b (patch)
tree6076fddafda7a16f8df2c9a8c132e4e10fe82ca9 /PKGBUILD
parentc278f5634b25fd7b48ceb661d6b252b14e8ee9d4 (diff)
downloadaur-dbus-broker-git.tar.gz
dbus-broker-git: align with non-git package
The non-git package was updated to provide the units as a sub-package. Align with that package again to provide the same functionality. Signed-off-by: David Rheinsberg <david@readahead.eu>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD141
1 files changed, 101 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 450a556a4467..cc474c2c870f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,127 @@
-# Maintainer: David Herrmann <dh.herrmann@gmail.com>
+# Maintainer: David Rheinsberg <david@readahead.eu>
-_pkgorg=bus1
-_pkgname=dbus-broker
-pkgdesc='Linux D-Bus Message Broker'
-pkgver=31.14.g5d475cf
+pkgbase="dbus-broker-git"
+pkgname=(
+ "dbus-broker-git"
+ "dbus-broker-units-git"
+)
+
+pkgdesc="Linux D-Bus Message Broker"
+pkgver=35.0.gb71a541
pkgrel=1
-pkgname=$_pkgname-git
-arch=('x86_64')
-url="https://github.com/$_pkgorg/$_pkgname"
-license=('Apache')
-depends=('audit>=3.0' 'expat>=2.2' 'libcap-ng>=0.6' 'linux>=4.17' 'systemd-libs>=230')
-makedepends=('git' 'meson>=0.60.0' 'systemd' 'python-docutils')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-
-source=("$pkgname::git+https://github.com/$_pkgorg/$_pkgname"
- "c-dvar-1::git+https://github.com/c-util/c-dvar#branch=v1"
- "c-ini-1::git+https://github.com/c-util/c-ini#branch=v1"
- "c-list-3::git+https://github.com/c-util/c-list#branch=v3"
- "c-rbtree-3::git+https://github.com/c-util/c-rbtree#branch=v3"
- "c-shquote-1::git+https://github.com/c-util/c-shquote#branch=v1"
- "c-stdaux-1::git+https://github.com/c-util/c-stdaux#branch=v1"
- "c-utf8-1::git+https://github.com/c-util/c-utf8#branch=v1")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+arch=("x86_64")
+license=("Apache-2.0")
+url="https://github.com/bus1/dbus-broker/wiki"
+
+depends=(
+ 'audit>=3.0'
+ 'expat>=2.2'
+ 'libcap-ng>=0.6'
+ 'linux>=4.17'
+ 'systemd-libs>=230'
+)
+makedepends=(
+ 'git'
+ 'meson>=0.60.0'
+ 'systemd'
+ 'python-docutils'
+)
+
+source=(
+ "$pkgbase::git+https://github.com/bus1/dbus-broker"
+ "c-dvar-1::git+https://github.com/c-util/c-dvar#branch=v1"
+ "c-ini-1::git+https://github.com/c-util/c-ini#branch=v1"
+ "c-list-3::git+https://github.com/c-util/c-list#branch=v3"
+ "c-rbtree-3::git+https://github.com/c-util/c-rbtree#branch=v3"
+ "c-shquote-1::git+https://github.com/c-util/c-shquote#branch=v1"
+ "c-stdaux-1::git+https://github.com/c-util/c-stdaux#branch=v1"
+ "c-utf8-1::git+https://github.com/c-util/c-utf8#branch=v1"
+ "0001-units-Enable-statically.patch"
+)
+
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
- cd $pkgname
+ cd "$pkgbase"
git describe --long --tags | sed 's/^v//;s/-/./g'
}
prepare() {
- cd $pkgname
+ cd "$pkgbase"
local sp
for sp in {dvar-1,ini-1,list-3,rbtree-3,shquote-1,stdaux-1,utf8-1}; do
ln -fs "$(realpath --relative-to "subprojects" "$srcdir/c-$sp")" "subprojects/libc$sp"
done
+
+ patch -Np1 -i "../0001-units-Enable-statically.patch"
}
build() {
- arch-meson $pkgname build \
- -D audit=true \
- -D docs=true \
- -D linux-4-17=true \
+ local meson_options=(
+ -D audit=true
+ -D docs=true
+ -D linux-4-17=true
-D system-console-users=gdm,sddm,lightdm,lxdm
- ninja -C build
+ )
+
+ arch-meson "$pkgbase" build "${meson_options[@]}"
+ meson compile -C build
}
check() {
meson test -C build --print-errorlogs
}
-package() {
- DESTDIR="$pkgdir" meson install -C build
+_pick() {
+ local p="$1" f d; shift
+ for f; do
+ d="$srcdir/$p/${f#$pkgdir/}"
+ mkdir -p "$(dirname "$d")"
+ mv "$f" "$d"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
+ done
+}
+
+package_dbus-broker-git() {
+ depends+=(
+ "libaudit.so"
+ "libcap-ng.so"
+ "libexpat.so"
+ "libsystemd.so"
+ )
+ provides=("dbus-broker")
+ conflicts=("dbus-broker")
+
+ meson install -C build --destdir "$pkgdir"
+
+ _pick unit "$pkgdir"/usr/lib/systemd/{system,user}/dbus.service
+}
+
+package_dbus-broker-units-git() {
+ pkgdesc+=" - Service units"
+ depends=("dbus-broker")
+ provides=(
+ "dbus-broker-units"
+ "dbus-units"
+ )
+ conflicts=(
+ "dbus-broker-units"
+ "dbus-daemon-units"
+ )
+
+ mv unit/* "$pkgdir"
}
-# vim:set sw=2 et:
+# vim:set sw=2 sts=-1 et: