summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIwan Timmer2018-03-15 22:33:15 +0100
committerIwan Timmer2018-03-15 22:33:15 +0100
commit92451d8c750c5ae1703e542bbd1277ef4ec297bd (patch)
tree62993717ba06e7877b9c014626cb40de4f40b166 /PKGBUILD
parente734596a524cb3f5e99759b47792d77b00d6c6e7 (diff)
downloadaur-92451d8c750c5ae1703e542bbd1277ef4ec297bd.tar.gz
Provide patch for Boost 1.66
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6bc9b51d07e..31c353c8194f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,20 @@ url="https://code.launchpad.net/dbus-cpp"
license=('LGPL3')
depends=('process-cpp' 'dbus' 'libxml2')
makedepends=('cmake' 'gmock' 'properties-cpp' 'boost')
-source=("https://launchpad.net/ubuntu/+archive/primary/+files/dbus-cpp_${_pkgver}.orig.tar.gz")
-md5sums=('61e9568f3c799214c5bc8b5e3a498496')
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/dbus-cpp_${_pkgver}.orig.tar.gz"
+ "boost-asio-1-66.patch")
+md5sums=('61e9568f3c799214c5bc8b5e3a498496'
+ '127dde628ffb8296516090228975cfc2')
prepare() {
cd "$srcdir"
# Don't build tests
truncate -s 0 tests/CMakeLists.txt
+
+ # Fix boost asio 1.66 API changes
+ # https://github.com/anbox/anbox/issues/637#issuecomment-373361974
+ patch -Np1 -i boost-asio-1-66.patch
}
build() {