summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2024-01-14 22:19:16 +0100
committerNicolas Iooss2024-01-14 22:19:16 +0100
commitcd58ced32efd9e30028ed674f873dae7c6d5c89e (patch)
tree2616d8cc81384468cb52ab72d6a1f74f155a7cc9 /PKGBUILD
parentb7a86642121b6c8969fb92241d24638a1cd6e6a3 (diff)
downloadaur-dbus-selinux.tar.gz
dbus-selinux 1.14.10-2 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 31 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9fa748e97d5..a60ffdb68d68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,57 +6,49 @@
#
# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
# If you want to help keep it up to date, please open a Pull Request there.
+#
+# This PKGBUILD does not build a variant for dbus-daemon-units, as there is nothing specific to SELinux there
-# When updating, if makepkg reports "dbus is not a clone of https://gitlab.freedesktop.org/dbus/dbus.git",
-# you need to update the remotes of the source git repository, for example with the following command:
-# git -C dbus remote set-url origin https://gitlab.freedesktop.org/dbus/dbus.git
pkgbase=dbus-selinux
pkgname=(
dbus-selinux
dbus-docs-selinux
)
pkgver=1.14.10
-pkgrel=1
+pkgrel=2
pkgdesc="Freedesktop.org message bus system with SELinux support"
url="https://wiki.freedesktop.org/www/Software/dbus/"
arch=(x86_64 aarch64)
-license=(
- GPL
- custom
-)
+license=("AFL-2.1 OR GPL-2.0-or-later")
groups=(selinux)
-# Make sure systemd's hook supports reloading dbus: the following commit was introduced in package systemd 242.84-2
-# https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/systemd&id=4e247891655844511c775fba566df270f8d0d55f
-# https://github.com/archlinux/svntogit-packages/commit/4e247891655844511c775fba566df270f8d0d55f
depends=(
audit
+ libcap-ng
expat
libselinux
'systemd-libs-selinux>=242.84-2'
)
makedepends=(
- autoconf-archive
docbook-xsl
doxygen
- git
python
systemd-selinux
xmlto
yelp-tools
)
source=(
- "git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
+ https://dbus.freedesktop.org/releases/dbus/dbus-$pkgver.tar.xz{,.asc}
dbus-reload.hook
)
-b2sums=('SKIP'
+b2sums=('f605b0810dcde6a0753384927131e7f4675be737ad7506a51261717c2622e74b99ac33cc2c199b98e5aa6b9d7c68ef692b8ee9f684f6fdab8d06c6fa861a6f6b'
+ 'SKIP'
'05ab81bf72e7cf45ad943f5b84eaecef4f06bed94979c579a3e23134cbabd7ea6f65fa9ac252f8b43ceb4a3295e0d2325f06560a044fe7ddf125fc30dfc2b7e2')
validpgpkeys=(
DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90 # Simon McVittie <simon.mcvittie@collabora.co.uk>
)
prepare() {
- cd dbus
- NOCONFIGURE=1 ./autogen.sh
+ cd dbus-$pkgver
}
build() {
@@ -83,18 +75,30 @@ build() {
--enable-selinux
)
- cd dbus
+ cd dbus-$pkgver
./configure "${configure_options[@]}"
make
}
check() {
- make -C dbus -j1 check
+ make -C dbus-$pkgver -j1 check
+}
+
+_pick() {
+ local p="$1" f d; shift
+ for f; do
+ d="$srcdir/$p/${f#$pkgdir/}"
+ mkdir -p "$(dirname "$d")"
+ mv "$f" "$d"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
+ done
}
package_dbus-selinux() {
depends+=(
libaudit.so
+ libcap-ng.so
+ libexpat.so
libsystemd.so
)
provides=(
@@ -107,21 +111,21 @@ package_dbus-selinux() {
conflicts=(libdbus libdbus-selinux "${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
replaces=(libdbus libdbus-selinux)
- DESTDIR="$pkgdir" make -C dbus install
+ cd dbus-$pkgver
+ DESTDIR="$pkgdir" make install
rm -r "$pkgdir"/{etc,var}
+ _pick unit "$pkgdir"/usr/lib/systemd/{system,user}/dbus.service
+ _pick docs "$pkgdir"/usr/share/doc
+
# We have a pre-assigned uid (81)
echo 'u dbus 81 "System Message Bus"' |
install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
- install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
-
- # Split docs
- mkdir -p doc/usr/share
- mv {"$pkgdir",doc}/usr/share/doc
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../*.hook
- install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING
}
package_dbus-docs-selinux() {
@@ -129,9 +133,7 @@ package_dbus-docs-selinux() {
depends=()
conflicts=("${pkgname/-selinux}")
- mv doc/* "$pkgdir"
-
- install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
+ mv docs/* "$pkgdir"
}
# vim:set sw=2 sts=-1 et: