summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2014-05-30 11:52:08 +0200
committerNicolas Iooss2014-05-30 12:01:41 +0200
commitad25e457ca19c259ec2d3f5879c52679894a29d9 (patch)
treecf499decfa255435c6f5f55b53601feaa2d42761 /PKGBUILD
downloadaur-ad25e457ca19c259ec2d3f5879c52679894a29d9.tar.gz
Add dbus-selinux 1.8.2-1 package
When compiled with SELinux support, DBus uses the SELinux policy to validate inter-process communication (class "dbus", permissions "acquire_svc" and "send_msg").
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 71 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee1d3e95f499
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# $Id$
+# Maintainer: Tom Gundersen <teg@jklm.no>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Link Dupont <link@subpop.net>
+# SELinux Contributor: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+#
+pkgbase=dbus-selinux
+pkgname=('dbus-selinux' 'libdbus-selinux')
+pkgver=1.8.2
+pkgrel=1
+pkgdesc="Freedesktop.org message bus system with SELinux support"
+url="http://www.freedesktop.org/Software/dbus"
+arch=(i686 x86_64)
+license=('GPL' 'custom')
+groups=('selinux')
+makedepends=('libx11' 'systemd-selinux' 'xmlto' 'docbook-xsl' 'audit')
+source=(http://dbus.freedesktop.org/releases/dbus/dbus-$pkgver.tar.gz{,.asc}
+ 30-dbus)
+md5sums=('d6f709bbec0a022a1847c7caec9d6068'
+ 'SKIP'
+ '3314d727fa57fc443fce25b5cbeebbcc')
+
+build() {
+ cd dbus-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=dbus \
+ --with-system-pid-file=/run/dbus/pid \
+ --with-system-socket=/run/dbus/system_bus_socket \
+ --with-console-auth-dir=/run/console/ \
+ --enable-inotify --disable-dnotify \
+ --disable-verbose-mode --disable-static \
+ --disable-tests --disable-asserts \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --enable-systemd \
+ --enable-selinux --enable-libaudit
+ make
+}
+
+package_dbus-selinux(){
+ depends=('libdbus' 'expat' 'audit')
+ optdepends=('libx11: dbus-launch support')
+ provides=('dbus-core' "${pkgname/-selinux}=${pkgver}-${pkgrel}" "selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
+ conflicts=('dbus-core' "${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
+ replaces=('dbus-core' "${pkgname/-selinux}")
+
+ cd dbus-$pkgver
+
+ # Disable installation of libdbus
+ sed -i -e 's/^SUBDIRS = dbus/SUBDIRS =/' Makefile
+
+ make DESTDIR="$pkgdir" install
+
+ rm -rf "${pkgdir}/var/run"
+ rm -rf "${pkgdir}/usr/lib/pkgconfig"
+
+ install -Dm755 ../30-dbus "$pkgdir/etc/X11/xinit/xinitrc.d/30-dbus"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/dbus/COPYING"
+}
+
+package_libdbus-selinux(){
+ pkgdesc="DBus library"
+ depends=('glibc')
+ provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}")
+ conflicts=("${pkgname/-selinux}")
+ replaces=("${pkgname/-selinux}")
+
+ cd dbus-$pkgver
+ make DESTDIR="$pkgdir" -C dbus install
+ make DESTDIR="$pkgdir" install-data-am
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/libdbus/COPYING"
+}