summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCody P Schafer2016-06-29 12:15:15 -0400
committerCody P Schafer2016-06-29 12:15:49 -0400
commit23ca3207d5091f40ae25a30f75add59573f16737 (patch)
treef1a529a14a2870b16fe8a89851a068d33246db22 /PKGBUILD
downloadaur-23ca3207d5091f40ae25a30f75add59573f16737.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..138dbfe13144
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Cody P Schafer <archlinux at codyps.com>
+_bpn=dbus-test-runner
+pkgname=${_bpn}-bzr
+pkgver=r39
+pkgrel=1
+pkgdesc="A small little utility to run a couple of executables under a new DBus session for testing"
+arch=(x86_64 )
+url="https://launchpad.net/dbus-test-runner"
+license=('GPLv3')
+groups=()
+depends=()
+makedepends=(bzr gnome-common)
+provides=(${_bpn})
+conflicts=(${_bpn})
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=($pkgname::bzr+http://bazaar.launchpad.net/~indicator-applet-developers/$_bpn/trunk)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s" "$(bzr revno)"
+}
+
+build() {
+ cd "$pkgname"
+ export CFLAGS="${CFLAGS:-} -Wno-error=deprecated -Wno-error=deprecated-declarations"
+ ./autogen.sh
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: