summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2019-02-12 02:37:02 +0900
committerQue Quotion2019-02-12 02:37:02 +0900
commit127ab1bbb4b75673a00242247cba91a48a22f745 (patch)
tree3bba1e9979a7c1f405d5a9029aacce3656a2624c /PKGBUILD
parent46e52747c8b70f6db170b6d98e1d708f84a336bf (diff)
downloadaur-127ab1bbb4b75673a00242247cba91a48a22f745.tar.gz
Update to 1.12.12; match configuration with [core] (except for x11 autolaunch)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD82
1 files changed, 45 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f167330c524b..142e32d5e14f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,74 +4,82 @@
# Contributor: Tom Gundersen <teg@jklm.no>
# Contributor: Link Dupont <link@subpop.net>
-pkgname=dbus-x11
-pkgver=1.10.18
+pkgbase=dbus-x11
+pkgname=(dbus-x11 dbus-docs)
+pkgver=1.12.12
pkgrel=1
-pkgdesc="Freedesktop.org message bus system"
+pkgdesc="Freedesktop.org message bus system (with x11 autolaunch)"
url="https://wiki.freedesktop.org/www/Software/dbus/"
-arch=(i686 x86_64)
+arch=(x86_64)
license=(GPL custom)
-provides=('libdbus' 'dbus' 'dbus-docs')
-conflicts=('libdbus' 'dbus' 'dbus-docs')
-replaces=(libdbus)
depends=(libsystemd expat)
-makedepends=(systemd xmlto docbook-xsl python yelp-tools doxygen git libx11)
-_commit=73961ee58cf47315b14e30fbde6d0eea825c987b # tags/dbus-1.10.18^0
-source=("git+https://anongit.freedesktop.org/git/dbus/dbus#commit=$_commit"
- 'dbus.sysusers')
-sha256sums=('SKIP'
- '1ce179ba3a92ad34941d8ac7f53d01d42cbc91d43ada1136492b78c10b5d693d')
+makedepends=(systemd xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive graphviz)
+_commit=d4f8423bbff9b3c5fca2d8009c28d1cff4652788 # tags/dbus-1.12.12^0
+source=("git+https://anongit.freedesktop.org/git/dbus/dbus#commit=$_commit")
+sha256sums=('SKIP')
validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90' # Simon McVittie <simon.mcvittie@collabora.co.uk>
'3C8672A0F49637FE064AC30F52A43A1E4B77B059') # Simon McVittie <simon.mcvittie@collabora.co.uk>
pkgver() {
- cd ${pkgname%-*}
+ cd dbus
git describe --tags | sed 's/^dbus-//;s/-/+/g'
}
prepare() {
- cd ${pkgname%-*}
- git cherry-pick -n 09cb6d7b467f6d1c6685ee9ccc171f4dddbe1f42
+ cd dbus
+
+ # Reduce docs size
+ printf '%s\n' >>Doxyfile.in \
+ HAVE_DOT=yes DOT_IMAGE_FORMAT=svg INTERACTIVE_SVG=yes
+
NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd ${pkgname%-*}
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=dbus \
- --with-system-pid-file=/run/dbus/pid \
- --with-system-socket=/run/dbus/system_bus_socket \
- --with-console-auth-dir=/run/console/ \
- --enable-inotify --disable-static \
- --disable-verbose-mode --disable-asserts \
- --with-systemdsystemunitdir=/usr/lib/systemd/system \
- --enable-systemd --enable-user-session \
- --enable-x11-autolaunch
+ cd dbus
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ runstatedir=/run \
+ --libexecdir=/usr/lib/dbus-1.0 \
+ --with-system-socket=/run/dbus/system_bus_socket \
+ --with-dbus-session-bus-connect-address=unix:runtime=yes \
+ --with-dbus-user=dbus \
+ --enable-user-session \
+ --disable-static \
+ --enable-x11-autolaunch
make
}
check() {
- cd ${pkgname%-*}
- make check
+ make -C dbus check
}
-package() {
- cd ${pkgname%-*}
+package_dbus-x11() {
+ provides=({,lib}dbus)
+ conflicts=(libdbus)
+ replaces=(libdbus)
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make -C dbus install
rm -r "$pkgdir/var/run"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/${pkgname%-*}/COPYING"
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
- # systemd-sysusers
- install -Dm644 "$srcdir/dbus.sysusers" "$pkgdir/usr/lib/sysusers.d/dbus.conf"
+ # We have a pre-assigned uid (81)
+ echo 'u dbus 81 "System Message Bus"' |
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
# Split docs
mv "$pkgdir/usr/share/doc" "$srcdir"
+}
+
+package_dbus-docs() {
+ pkgdesc+=" (documentation)"
+ depends=()
- install -d "$pkgdir/usr/share/licenses"
- ln -s dbus "$pkgdir/usr/share/licenses/dbus-docs"
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
mv doc "$pkgdir/usr/share"
}