summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNoah Vogt2023-09-11 16:07:55 +0200
committerNoah Vogt2023-09-11 16:07:55 +0200
commit2e5ba31c8013bace4f11a408c16554db98e95d84 (patch)
tree101d2635670e33ba818763292ceafa663470a3b8 /PKGBUILD
parent3cb5d5912554187308a28daf954760cdf15d6bc9 (diff)
downloadaur-2e5ba31c8013bace4f11a408c16554db98e95d84.tar.gz
uppkg -> 1.14.10-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 23 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58366aead865..f3e7375902ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,9 @@ pkgname=(
dbus-xdg-elogind
dbus-xdg-docs
)
-pkgver=1.14.6
+pkgver=1.14.10
pkgrel=1
-pkgdesc="Freedesktop.org message bus system - but do not create a ~/.dbus directory (for non-systemd systems)"
+pkgdesc="Freedesktop.org message bus system - without creating a ~/.dbus directory (for non-systemd systems)"
url="https://wiki.freedesktop.org/www/Software/dbus/"
arch=(x86_64)
license=(
@@ -22,9 +22,10 @@ depends=(
audit
expat
libelogind
+ libx11
)
makedepends=(
-autoconf-archive
+ autoconf-archive
docbook-xsl
doxygen
git
@@ -60,25 +61,25 @@ prepare() {
build() {
local configure_options=(
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/usr/lib/dbus-1.0 \
- --runstatedir=/run \
- --with-console-auth-dir=/run/console/ \
- --with-dbus-user=dbus \
- --with-system-pid-file=/run/dbus/pid \
- --with-system-socket=/run/dbus/system_bus_socket \
- --without-systemdsystemunitdir \
- --enable-inotify \
- --enable-libaudit \
- --disable-systemd \
- --disable-user-session \
- --enable-xml-docs \
- --enable-doxygen-docs \
- --enable-ducktype-docs \
- --disable-static \
- --enable-elogind \
+ --prefix=/usr
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --libexecdir=/usr/lib/dbus-1.0
+ --runstatedir=/run
+ --with-console-auth-dir=/run/console/
+ --with-dbus-user=dbus
+ --with-system-pid-file=/run/dbus/pid
+ --with-system-socket=/run/dbus/system_bus_socket
+ --without-systemdsystemunitdir
+ --enable-inotify
+ --enable-libaudit
+ --disable-systemd
+ --disable-user-session
+ --enable-xml-docs
+ --enable-doxygen-docs
+ --enable-ducktype-docs
+ --disable-static
+ --enable-elogind
--enable-x11-autolaunch
)