summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2024-01-30 21:11:22 +0100
committerPeter Mattern2024-01-30 21:11:22 +0100
commit82a970ca002e0b3ad5b993aabf54608393903dac (patch)
treee9d0ab0cfbcb5a2dbe3c234256a20b87945299b6 /PKGBUILD
parent2b1da9b3b9790da5e5e2f2ee3a4bb901337bd4c0 (diff)
downloadaur-dcmtk-git.tar.gz
Improve pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e6b92052b95..3b596fb5a06a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=dcmtk
pkgname=$_pkgname-git
-pkgver=3.6.1_20170228.43.gef9173b95
+pkgver=3.6.8.r54.gc791af76e
pkgrel=1
pkgdesc='Collection of libraries and applications implementing large parts the DICOM standard'
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ sha256sums=("SKIP")
pkgver() {
cd $_pkgname
- git describe --always | sed 's:^DCMTK-::;s:-:.:g'
+ git describe --always | sed 's/^DCMTK-//;s/-/.r/;s/-/./'
}
build() {