summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2024-01-30 21:07:28 +0100
committerPeter Mattern2024-01-30 21:07:28 +0100
commit2b1da9b3b9790da5e5e2f2ee3a4bb901337bd4c0 (patch)
tree02f4527157cb4e2d17f99bb9b31b50f6dbb08a9c /PKGBUILD
parent0757f79d0e4a664861958397a012df119c71eeaf (diff)
downloadaur-2b1da9b3b9790da5e5e2f2ee3a4bb901337bd4c0.tar.gz
Update dependencies and build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9359609f67b5..4e6b92052b95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,11 @@ pkgdesc='Collection of libraries and applications implementing large parts the D
arch=('i686' 'x86_64')
url='https://dicom.offis.de/dcmtk'
license=('custom')
-depends=('libxml2' 'libwrap' 'libjpeg-turbo' 'libpng' 'libtiff')
-makedepends=('git' 'cmake' 'libsndfile' 'doxygen')
+depends=('libxml2' 'libsndfile' 'libpng' 'libtiff' 'libjpeg-turbo')
+makedepends=('git' 'cmake' 'doxygen')
provides=("$_pkgname")
-conflicts=("$_pkgname"{,-snapshot})
-backup=("etc/dcmtk/"{dcmpstat,dcmqrscp,filelog,logger,printers,storescp,storescu}.cfg)
+conflicts=("$_pkgname")
+backup=("etc/dcmtk-${pkgver%.r*}-DEV/"{dcmpstat,dcmqrprf,dcmqrscp,filelog,logger,printers,storescp,storescu}.cfg)
source=("git+https://git.dcmtk.org/dcmtk.git")
sha256sums=("SKIP")
@@ -26,9 +26,8 @@ build() {
cd build
cmake "$srcdir/$_pkgname" \
-DDCMTK_ENABLE_CHARSET_CONVERSION=ICU \
- -DDCMTK_USE_CXX11_STL=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DDCMTK_INSTALL_ETCDIR=/etc/dcmtk \
+ -DCMAKE_INSTALL_SYSCONFDIR:PATH=/etc \
-DBUILD_SHARED_LIBS=ON
make
make html