summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorandy59952021-07-09 13:33:51 -0500
committerandy59952021-07-09 13:33:51 -0500
commit43f994d813030ceaff168fea58a12f84bca09051 (patch)
tree0e6115fcc4f00dc57d25373ddc80956c09441b03 /PKGBUILD
parent717b82b33b6dc3b90dbdac9d71338947a8dbb3c8 (diff)
downloadaur-43f994d813030ceaff168fea58a12f84bca09051.tar.gz
Revert "apply 4 patches (from Slackware source)"
This reverts commit 717b82b33b6dc3b90dbdac9d71338947a8dbb3c8. I'm just not confident enough of my changes so I'm reverting and will disown this package to leave it free for someone else.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 7 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e48d94bdbde3..b3e372eb4f69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
-# Maintainer: Andy Alt <andy400-dev at yahoo dot com>
-# Contributor: gt <AT> notfoss.com
+# Maintainer: gt <AT> notfoss.com
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: Paul Mattal <paul.archlinux.org>
pkgname="dcron"
pkgver="4.5"
-pkgrel="9"
+pkgrel="8"
pkgdesc="dillon's lightweight cron daemon"
arch=("i686" "x86_64" "armv6h" "armv7h")
license=("GPL")
@@ -16,46 +15,22 @@ optdepends=("msmtp-mta: sending cron job output via email")
provides=("cron")
conflicts=("cron")
source=("http://www.jimpryor.net/linux/releases/${pkgname}-${pkgver}.tar.gz"
- "service"
- "crontab.c.O_EXCL.diff"
- "dcron.update.during.long.running.jobs.diff"
- "defs.h.TMPDIR.diff"
- "defs.h._DEFAULT_SOURCE.diff")
+ "service")
md5sums=("078833f3281f96944fc30392b1888326"
- "2eefc422db24bf2ac38e3a16292ccdc4"
- "60ccc2d785edcbfaa0b5dcbda5b9ebea"
- "da30bc48e1f88f72bb3de38fe24bef51"
- "de9f7b8831585a871c6b3c3e1a1514c5"
- "54326a7f54633f69cf28def6bba87fce")
+ "2eefc422db24bf2ac38e3a16292ccdc4")
build() {
cd "$srcdir/${pkgname}-${pkgver}"
- # These 4 patches were obtained from Slackware sources at
- # https://mirrors.slackware.com/slackware/slackware64-14.2/source/a/dcron/
-
- # Define TMPDIR as /var/spool/cron instead of /tmp
- patch --verbose -p1 < ../../defs.h.TMPDIR.diff || exit 1
-
- # Fix problem where user creates /var/spool/cron/crontabs/<user>.new
- # using 'crontab -', exits with control-c, and then crontab refuses to
- # overwrite the junk file. It would be better if dcron would wipe
- # the junk file in the event it were not closed correctly, but oh well.
- patch --verbose -p1 < ../../crontab.c.O_EXCL.diff || exit 1
-
- # Running jobs should not block cron.update:
- patch --verbose -p1 < ../../$CWD/dcron.update.during.long.running.jobs.diff || exit 1
-
- # Change _BSD_SOURCE to _DEFAULT_SOURCE for recent glibc:
- patch --verbose -p1 < ../../defs.h._DEFAULT_SOURCE.diff || exit 1
-
# fix paths to point to /usr/bin
sed -i 's=/usr/sbin/sendmail=/usr/bin/sendmail=g' defs.h
sed -i 's=/usr/sbin/run-cron=/usr/bin/run-cron=g' extra/root.crontab
+ # by default, any member of group "users" can edit their own crontab
make \
PREFIX=/usr \
SBINDIR=/usr/bin \
+ CRONTAB_GROUP=users \
CRONTABS=/var/spool/cron \
CRONSTAMPS=/var/spool/cronstamps
}
@@ -63,12 +38,10 @@ build() {
package() {
cd "$srcdir/${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
- chmod 4711 "$pkgdir"/usr/bin/crontab
- chmod 0751 "$pkgdir"/var/spool/cron
- chmod 0750 "$pkgdir"/var/spool/cron "$pkgdir"/var/spool/cronstamps
# install standard configuration and scripts
install -d -m755 "$pkgdir"/etc/cron.{hourly,daily,weekly,monthly}
+
install -D -m755 extra/run-cron "$pkgdir"/usr/bin/run-cron
install -D -m0600 extra/root.crontab "$pkgdir"/var/spool/cron/root
install -D -m0644 extra/crond.conf "$pkgdir"/etc/conf.d/crond