summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrdotx2023-03-24 15:50:01 +0100
committermrdotx2023-03-24 15:50:01 +0100
commitaf4fd0fa4feb7cdd6e257f0d40fe6ce5ed1764d6 (patch)
treecf1c972407e091d7ddb95f5f91e493c283f7d260 /PKGBUILD
parent9fe864fb27805539cf95a1840bd7522bf7aaf779 (diff)
downloadaur-ddccontrol-git.tar.gz
pkgbuild updated and .gitignore added
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 30 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2dda6a0f269c..91f435b0eb2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
-# Maintainer: nutcase84 <nutcase84 at protronmail dot com>
+# Maintainer: mrdotx <klassiker@gmx.de>
+# Contributor: nutcase84 <nutcase84 at protronmail dot com>
# Contributor: kfgz <kfgz at interia pl>
# Contributor: Hubert CzobodziЕ„ski <hcz at onet dot eu>
# Contributor: Nathan Owe <ndowens dot aur at gmail dot com>
-
-pkgname=ddccontrol-git
_pkgname=ddccontrol
-pkgver=20180317.r7a7cdb4
+pkgname=ddccontrol-git
+pkgver=20220914.r26957e0
pkgrel=1
-pkgdesc="Control your monitor by software using the DDC/CI protocol."
+pkgdesc='Control your monitor by software using the DDC/CI protocol.'
arch=('i686' 'x86_64')
-url="https://github.com/ddccontrol/ddccontrol"
+url='https://github.com/ddccontrol/ddccontrol'
license=('GPL')
-depends=('pciutils' 'libxml2' 'ddccontrol-db-git')
-makedepends=('git' 'intltool')
+depends=(
+ 'pciutils'
+ 'libxml2'
+ 'ddccontrol-db-git'
+)
+makedepends=(
+ 'git'
+ 'intltool'
+)
provides=('ddccontrol')
conflicts=('ddccontrol')
source=(git+https://github.com/ddccontrol/ddccontrol.git)
@@ -20,32 +27,31 @@ options=('!libtool')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
- _gitver="$(git show -s --format="%ci %h" 2> /dev/null)"
- _gitver="${_gitver//[^[:alnum:][:space:]]/}"
+ _gitver="$(git show -s --format="%ci %h" 2> /dev/null)"
+ _gitver="${_gitver//[^[:alnum:][:space:]]/}"
- echo "${_gitver%% *}.r${_gitver##* }"
+ echo "${_gitver%% *}.r${_gitver##* }"
}
prepare() {
- cd "$srcdir/$_pkgname"
- # PKGBUILD should be non-interactive...
- sed -e 's:read dummy < /dev/tty::' "$(which gettextize)" > gettextize
- chmod +x gettextize
+ cd "$_pkgname"
+ # PKGBUILD should be non-interactive...
+ sed -e 's:read dummy < /dev/tty::' "$(which gettextize)" > gettextize
+ chmod +x gettextize
- sed -e 's:^gettextize :./gettextize :' -i autogen.sh
+ sed -e 's:^gettextize :./gettextize :' -i autogen.sh
}
build() {
- cd "$srcdir/$_pkgname"
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc
- make
+ cd "$_pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
}
package() {
- cd "$srcdir/$_pkgname"
- make DESTDIR="${pkgdir}" install
- #chmod 755 "${pkgdir}"/usr/bin/ddcpci
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
}