summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcbrannon2012-03-14 20:00:12 +0000
committercbrannon2012-03-14 20:00:12 +0000
commit118e8fb5bfdbbabe0b3364ed846bbf501473d5c7 (patch)
treec2cc10a1acd6a21e3adeec703d0a60f98a84c022 /PKGBUILD
parent77015db52df304fdba54b3836db62f9aa9d1078a (diff)
downloadaur-118e8fb5bfdbbabe0b3364ed846bbf501473d5c7.tar.gz
upgpkg: ddclient 3.8.1-3
Fix for FS#28718. ddclient used ifconfig -a to detect the IP address of an interface. I applied a patch so that it uses iproute2s git-svn-id: file:///srv/repos/svn-community/svn@67835 9fca08f4-af9d-4005-b8df-a31f2cc04f65
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c39c05742b1d..00d2bc39362c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ddclient
pkgver=3.8.1
-pkgrel=2
+pkgrel=3
pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services."
arch=('any')
url="http://ddclient.sourceforge.net/"
@@ -12,7 +12,16 @@ license=('GPL2')
depends=('perl' 'perl-io-socket-ssl')
backup=('etc/ddclient/ddclient.conf' 'etc/conf.d/ddclient')
install=ddclient.install
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2 ddclient.rc ddclient.conf.d)
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
+ ddclient.rc
+ ddclient.conf.d
+ iproute2.patch)
+
+build() {
+ cd ${srcdir}/ddclient-${pkgver}
+
+ patch -p1 < "$srcdir/iproute2.patch"
+}
package() {
cd ${srcdir}/ddclient-${pkgver}
@@ -32,4 +41,5 @@ package() {
}
md5sums=('7fa417bc65f8f0e6ce78418a4f631988'
'10af4667b7269132b8f0cdfc26864d89'
- 'b8f39c82827776da948b76ef83544d33')
+ 'b8f39c82827776da948b76ef83544d33'
+ 'e0c8a07e9b7a69e73cecd8626f16e8f0')