summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDenton Liu2020-05-25 22:15:12 -0400
committerDenton Liu2020-05-25 22:20:25 -0400
commit7dc5483bda0e900c9d594549936f27fafab6608d (patch)
tree2d80994876d9406c7183142486ef56891c55651b /PKGBUILD
parent49d54e1a1c15a3805642a235fff3355081443e2b (diff)
downloadaur-7dc5483bda0e900c9d594549936f27fafab6608d.tar.gz
PKGBUILD: fix incorrect file names
Since merging changes from upstream, $_gitname was mistakenly replaced with $pkgdir everywhere. Since we want to merge from upstream with as few conflicts as possible, as a hack, set $pkgname to $_gitname within package(). Reported-by: Nick Dumas
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f96fd4b9e43..1bb7a28d7f8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=ddclient-git
_gitname="${pkgname%-git}"
pkgver=v3.8.3.r317.g7a99919
-pkgrel=1
+pkgrel=2
pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services"
url="https://github.com/ddclient/ddclient"
@@ -34,6 +34,10 @@ pkgver() {
}
package() {
+ # hack so that we can merge in changes from upstream without changing all the
+ # $pkgname to $_gitname
+ pkgname="$_gitname"
+
cd ddclient
install -Dm755 ddclient "$pkgdir"/usr/bin/$pkgname