summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlessandro2017-10-15 15:54:15 -0700
committerAlessandro2017-10-15 15:54:15 -0700
commitbefcd72ab26272c5bdb1889d296b51ab6a7597c5 (patch)
treecf65ef2cbc3774b0d74b3d3dfb9dba28640ec07c /PKGBUILD
parentee0a7b561f405f9d4db419d133c316e99ccbb1ac (diff)
downloadaur-befcd72ab26272c5bdb1889d296b51ab6a7597c5.tar.gz
updated pkbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e2959a913f7..c8d6ad1a8211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,11 @@ pkgname=ddgtk
pkgver=0.1.r3.g5b25b7c
pkgrel=1
pkgdesc='A fronted Gui to dd for making bootable usb disks'
-arch=('i686' 'x86_64')
+arch=('any')
license=('GPL3')
url="https://github.com/gort818/${pkgname%-git}"
depends=('python3' 'python-gobject' 'gtk3' 'vte')
makedepends=('git' 'meson')
-options=('!emptydirs')
source=('ddgtk::git+https://github.com/gort818/ddgtk#branch=master')
sha1sums=('SKIP')
provides=("${pkgname%-git}")
@@ -22,11 +21,12 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- meson build
+ mkdir build
cd "$srcdir/${pkgname%-git}/build"
+ meson
ninja
}
package() {
cd "$srcdir/${pkgname%-git}/build"
- sudo ninja install
+ DESTDIR="$pkgdir" ninja install
}