summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2019-03-19 13:18:04 -0300
committerRafael Fontenelle2019-03-19 13:18:06 -0300
commitd5e7efd115a056b6082b0b059e4ab4de2f81d7aa (patch)
treedc6f0ad40e6ed5837819b4fd00cc3bce3924afb2 /PKGBUILD
parent75c985e8e69f0ae909f643a96866ac910c048e35 (diff)
downloadaur-d5e7efd115a056b6082b0b059e4ab4de2f81d7aa.tar.gz
Add websockets support
Why not?
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c85fee29e08e..1a8612d5b0ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=ddnet
pkgver=11.9
-pkgrel=1
+pkgrel=2
pkgdesc="DDraceNetwork, a cooperative racing mod of Teeworlds"
arch=('x86_64')
url="https://ddnet.tw"
license=('custom:BSD' 'CCPL:by-nc-sa')
-depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack')
+depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'libwebsockets')
makedepends=('cmake' 'python' 'imagemagick' 'gendesk')
checkdepends=('gtest')
optdepends=('ddnet-skins: more skins for your tee'
@@ -50,6 +50,7 @@ build() {
cmake ../DDNet-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DWEBSOCKETS=ON \
-DAUTOUPDATE=OFF
make all tools
}