summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKieran Colford2016-11-27 11:32:31 -0500
committerKieran Colford2016-11-27 11:32:31 -0500
commitf9cf4748a1e4619bb46fa9d40174d23a52bdf688 (patch)
tree0df333e78c104c2a5b73ae7b834d94ca2ed07f91 /PKGBUILD
downloadaur-f9cf4748a1e4619bb46fa9d40174d23a52bdf688.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1539f5fd07cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Kieran Colford <kieran@kcolford.com>
+pkgname=ddns
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="Automatic provisioning of Dynamic DNS."
+arch=('i686' 'x86_64')
+url=""
+license=('GPL')
+groups=()
+depends=('bind-tools' 'bash' 'curl')
+makedepends=()
+checkdepends=()
+optdepends=('bind: for tsig-keygen')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/kcolford/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('01e87d12c670fd985ed63d00b37d0acd')
+noextract=()
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 ddns.sh "$pkgdir/usr/bin/ddns.sh"
+ install -Dm644 systemd/ddns.service "$pkgdir/usr/lib/systemd/system/ddns.service"
+ install -Dm644 systemd/ddns.timer "$pkgdir/usr/lib/systemd/system/ddns.timer"
+ mkdir -pm700 "$pkgdir/etc/ddns/"
+}
+
+# vim:set ts=2 sw=2 et: