summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaphaël Doursenaud2018-02-10 12:16:41 +0100
committerRaphaël Doursenaud2018-02-10 12:16:41 +0100
commit6f83a94f08b3f37c611f833fcf8ce82e872564e5 (patch)
tree8ff86accc9926f2031aa8d191ebc14b8b377b1bd /PKGBUILD
parentf4da7f2350f5173e05d6e39b618d467f5e042da4 (diff)
downloadaur-6f83a94f08b3f37c611f833fcf8ce82e872564e5.tar.gz
Fix pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad229666bdf2..7174b8105193 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Raphaël Doursenaud <rdoursenaud@free.fr>
pkgbase=deadbeef-plugin-waveform-git
pkgname=(deadbeef-plugin-waveform-gtk2-git deadbeef-plugin-waveform-gtk3-git)
-pkgver=r158
+pkgver=v0.5.r66.g8420ca0
pkgrel=1
_pkgdesc="Waveform Seekbar Plugin for the DeaDBeeF audio player (development version)"
url="https://github.com/cboxdoerfer/ddb_waveform_seekbar"
@@ -16,16 +16,12 @@ md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${_gitname}"
- printf "r""$(git rev-list --count HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${_gitname}"
-
- touch AUTHORS
- touch ChangeLog
-
make
}
@@ -34,7 +30,6 @@ package_deadbeef-plugin-waveform-gtk2-git() {
depends=('deadbeef' 'sqlite' 'gtk2')
conflicts=('deadbeef-plugin-waveform-gtk2')
provides=('deadbeef-plugin-waveform-gtk2')
-
install -D -v -c "${srcdir}/${_gitname}/gtk2/ddb_misc_waveform_GTK2.so" "${pkgdir}/usr/lib/deadbeef/ddb_misc_waveform_GTK2.so"
}