summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorphuhl2023-08-06 21:12:47 +0200
committerphuhl2023-08-06 21:12:47 +0200
commita8923ff5e290d898a2a55c9d3b0a399567117502 (patch)
tree654efcecf382e5d0fb04901663eb44ae4e993aa9 /PKGBUILD
parentc2158746f51587c8a5fedae6e25513533486ce3b (diff)
downloadaur-a8923ff5e290d898a2a55c9d3b0a399567117502.tar.gz
Bumps version, updates source url
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9afc3b685ef..551db0e98240 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philipp Uhl <philipp.uhl@rwth-aachen.de>
pkgname=deadd-notification-center-bin
-pkgver=2.0.4
+pkgver=2.1.1
pkgrel=1
pkgdesc="Customizable notification-daemon with notification center"
url="https://github.com/phuhl/linux_notification_center"
@@ -10,10 +10,15 @@ arch=('x86_64')
depends=('gobject-introspection-runtime' 'gtk3')
provides=('deadd-notification-center')
conflicts=('deadd-notification-center' 'deadd-notification-center-git')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phuhl/linux_notification_center/archive/${pkgver}.tar.gz")
+DLAGENTS=('https::/usr/bin/curl -L -o %o %u')
+source=(
+ "deadd-notification-center::https://github.com/phuhl/linux_notification_center/releases/download/${pkgver}/deadd-notification-center",
+ "${pkgname}-${pkgver}.tar.gz::https://codeload.github.com/phuhl/linux_notification_center/tar.gz/refs/tags/${pkgver}")
prepare() {
tar -zxvf "${pkgname}-${pkgver}.tar.gz"
+ mkdir "linux_notification_center-${pkgver}/.out"
+ mv deadd-notification-center "linux_notification_center-${pkgver}/.out/deadd-notification-center"
}
build() {
@@ -26,4 +31,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha256sums=('81913079122d9c2057b75ca5284620bdb0f29e043e1fbf33273127a8aeb85b86')
+sha256sums=('0019dfc4b32d63c1392aa264aed2253c1e0c2fb09216f8e2cc269bbfb8bb49b5'
+ 'e83cae52aff076da8f199d64580e921eeab029aca6214937ab38a6c43145862b')