summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Wells2023-02-07 10:59:24 -0500
committerDavid Wells2023-02-07 10:59:29 -0500
commit4aa07c4f89f81446cd16c445a9fbe91abee04020 (patch)
tree55fd3b9de2397d19f769251ff1bb5b2f49ba2fa2 /PKGBUILD
parent50d163dcadaf355ff6b9c1f34d05953803f1537e (diff)
downloadaur-4aa07c4f89f81446cd16c445a9fbe91abee04020.tar.gz
Update to 9.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 134dae016130..c7364c7ee6b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=deal-ii
_realname=dealii
-pkgver=9.4.1
-pkgrel=2
+pkgver=9.4.2
+pkgrel=1
pkgdesc="An Open Source Finite Element Differential Equations Analysis Library"
arch=("i686" "x86_64")
url="http://www.dealii.org/"
@@ -42,7 +42,7 @@ optdepends=(
makedepends=('cmake')
install=deal-ii.install
source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz)
-sha1sums=('c49bb0d3f0341674b5e3865df730fbef7a2a9d5c')
+sha1sums=('ea4b5fadb45a34f4f9399d305548671a8059760b')
# where to install deal.II: change to something else (e.g., /opt/deal.II/)
# if desired.
_installation_prefix=/usr
@@ -103,7 +103,6 @@ build() {
cmake_configuration_flags+=" -DLAPACK_INCLUDE_DIRS=${MKLROOT}/include"
fi
-
# For GSL compatibility we need the full link interface, which includes
# libgslcblas, so disable --as-needed with GCC:
sed -i '/ENABLE_IF_LINKS(DEAL_II_LINKER_FLAGS "-Wl,--as-needed")/d' \
@@ -112,9 +111,6 @@ build() {
sed -i '122ifedisableexcept(FE_INVALID);\n' \
${srcdir}/${_realname}-$pkgver/tests/quick_tests/scalapack.cc
- sed -i '146i#include <boost/algorithm/string/case_conv.hpp>\n' \
- ${srcdir}/${_realname}-$pkgver/examples/step-70/step-70.cc
-
# Also remove from LDFLAGS if necessary
LDFLAGS=$(echo $LDFLAGS | sed 's/--as-needed,//')