summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Wells2018-10-14 23:21:45 -0400
committerDavid Wells2018-10-14 23:21:45 -0400
commit5ba998f43e206b86542d694384bd8de559b2de76 (patch)
treefcac4d8178825534fd29953b29d9c7e40ea39fd6 /PKGBUILD
parent6915afea0512745dace6b3c10377c144823002ce (diff)
downloadaur-5ba998f43e206b86542d694384bd8de559b2de76.tar.gz
Fix linking with GSL.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9979a89de756..95371741fa02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -90,6 +90,18 @@ build() {
fi
fi
+ # For GSL compatibility we need the full link interface, which includes
+ # libgslcblas, so disable --as-needed with GCC:
+ sed -i '/ENABLE_IF_LINKS(DEAL_II_LINKER_FLAGS "-Wl,--as-needed")/d' \
+ ${srcdir}/${_realname}-$pkgver/cmake/setup_compiler_flags_gnu.cmake
+
+ sed -i '116ifedisableexcept(FE_INVALID);\n' \
+ ${srcdir}/${_realname}-$pkgver/tests/quick_tests/scalapack.cc
+
+
+ # Also remove from LDFLAGS if necessary
+ LDFLAGS=$(echo $LDFLAGS | sed 's/--as-needed,//')
+
# Skip some warnings that appear if Trilinos uses OpenMP pragmas in headers:
extra_warning_flags=" -Wno-unknown-pragmas"