summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Dewender2014-01-11 19:41:03 +0100
committerJohannes Dewender2014-01-11 19:41:03 +0100
commit194739bf01706259930c0c50edf6310cacc702cc (patch)
treee79cf6885905e76ab43d2a5c91fb25581d0ee0ed /PKGBUILD
parent96013c62747879cef5e1e1e3a76a803032a44069 (diff)
downloadaur-194739bf01706259930c0c50edf6310cacc702cc.tar.gz
debhelper-python: fix check
check() didn't work when the package wasn't already installed.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c17d5f2bcee1..5f33e776af13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=python3-defaults
_pkgname2=dh-python
pkgver=3.3.2
_pkgver=1.20130917
-pkgrel=1
+pkgrel=2
_pkgrel=17
pkgdesc="debhelper scripts for Python 3: py3versions, python3.pm"
arch=('any')
@@ -40,7 +40,11 @@ build() {
check() {
cd "$srcdir/$_pkgname-debian"
+ sed -i -e 's|/usr/share/python3/debian_defaults|debian/debian_defaults|' \
+ debpython/version.py
make -k check_versions
+ sed -i -e 's|debian/debian_defaults|/usr/share/python3/debian_defaults|' \
+ debpython/version.py
}
package() {