summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPSposito2020-02-24 11:07:46 +0200
committerPSposito2020-02-24 11:07:46 +0200
commit48b17c965b575f9fe52941964b0d677e4c3931df (patch)
treeada2532721f9d535a94f0c26c5eaea876e29056b /PKGBUILD
downloadaur-48b17c965b575f9fe52941964b0d677e4c3931df.tar.gz
Initial release.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5d4dc4aeda1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: PSposito <http://bit.do/linuxer>
+# <https://gitlab.com/psposito>
+# Maintainer: Justin Vreeland <vreeland.justin@gmail.com>
+# Contributor: Antoine Lubineau <antoine@lubignon.info>
+# Contributor: Charles Pigott <charlespigott@googlemail.com>
+# Contributor: Andrei "Garoth" Thorp <garoth "at the nice" gmail "dot" com>
+
+pkgname=debhelpergit
+pkgver=12.9
+pkgrel=1
+pkgdesc="A collection of programs that can be used in a debian/rules file to automate common tasks"
+arch=('any')
+url="https://salsa.debian.org/debian/debhelper.git/"
+license=('GPL2' 'GPL3')
+depends=('binutils' 'dpkg>=1.16.2' 'file>=3.23' 'html2text' 'man-db>=2.5.1' 'perl>=5.6.0' 'po-debconf')
+makedepends=('po4a>=0.24' 'man-db>=2.5.1' 'file>=3.23' 'git')
+optdepends=('dh-make')
+source=("git+https://salsa.debian.org/debian//debhelper.git#tag=debian/$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: