summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Pujol2019-11-17 18:11:38 +0000
committerAlexandre Pujol2019-11-17 18:11:38 +0000
commit581f54c9fa2e18b46f184568dca8914e396d1584 (patch)
tree85eca3bbfae61d217beb9784a19b91f145141b29 /PKGBUILD
parent608a159274f4f1fe24ccafda3bff8bf936a9cfd5 (diff)
downloadaur-581f54c9fa2e18b46f184568dca8914e396d1584.tar.gz
upgpkg: debops 1.1.5-1
upstream release debops 1.1.5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f947b0e956de..0b16337afa83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# Maintainer: itsme <mymail@ishere.ru>
-
+# Maintainer: Alexandre Pujol <alexandre@pujol.io>
+# Contributor: DebOps project https://debops.org/
+# Contributor: Maciej Delmanowski <drybjed@gmail.com>
+# Contributor: itsme <mymail@ishere.ru>
pkgname=debops
-pkgver=0.8.0
+pkgver=1.1.5
pkgrel=1
-pkgdesc="A collection of Ansible playbooks, scalable from one container to an entire data center."
+pkgdesc="Your Debian-based data center in a box"
arch=('any')
url="http://debops.org/"
license=('GPL3')
-depends=('python' 'ansible' 'python-netaddr' 'python-ldap' 'python-passlib' 'util-linux' 'encfs' 'gnupg' 'python-dnspython')
+depends=('python' 'ansible' 'python-future' 'util-linux' 'encfs' 'gnupg')
+optdepends=(
+ 'python-dnspython: required by Ansible "dig" module'
+ 'python-pyopenssl: required by "openssl_*" Ansible modules'
+ 'python-netaddr: required by Ansible "ipaddr" filter plugin'
+ 'python-ldap: required by Ansible "ldap_*" modules'
+ 'python-passlib: required by Ansible "password" lookup plugin')
makedepends=('python-setuptools')
conflicts=('depops-git')
-source=("https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('0068745fdf79f57a3d1436b88b5849421b1f48c9c5c64da450e51ce9022b0c70')
+source=(https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz)
+sha512sums=('a77d5efcbf777fe1bdcbd5679487bb448f6e4a1ea536f192849f1e613b97e80c562e7b348885ade4b88b0c422148c9bd5cea4ecc0f6bd0d5773094379365c166')
build() {
- cd "${pkgname}-${pkgver}"
- python setup.py build
+ cd "$pkgname-$pkgver"
+ python setup.py build
}
package() {
- cd "${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
}