summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEthan Kerrick2022-06-09 15:10:55 -0400
committerEthan Kerrick2022-06-09 15:10:55 -0400
commitd2a0eb93ec88a267c71a17dd2ecadb22cf88c210 (patch)
tree6b4f60c2ba6c0431ff1352bfd9c3e0923345bbe8 /PKGBUILD
downloadaur-d2a0eb93ec88a267c71a17dd2ecadb22cf88c210.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b07d74b74d3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: silverhikari <kerrickethan@gmail.com>
+pkgname=decent-sampler-bin
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="a sampling plugin that allows you to play samples in the Decent Sampler format"
+arch=(x86_64)
+url="https://www.decentsamples.com/product/decent-sampler-plugin/"
+license=('nonfree')
+depends=('alsa-lib' 'freetype2')
+provides=('decent-sampler')
+source=("local://Decent_Sampler-${pkgver}-Linux-x86_64.tar.gz" "decent sampler.png" "decent sampler.desktop" "application-decent-sampler.xml")
+sha256sums=('a68a6f4d84a6ed0527dd6b1c612360bf40ec8afdd95506c626988fa23d28c53b' '8e8654c1af4fb823b088fba806f6577ca5ca4d3c0eb76e29af0b650d52b617de' 'd0bb836f05373d3493a6b2be7d90beeb6119f996199ee5856a92ba681914f0b0' 'f45eefe4e35d6973e55af2ff3a07d392273b2141dc8ff025c0f86597bbb90bb8')
+
+package() {
+ cd "Decent_Sampler-${pkgver}-Linux-x86_64"
+ install -Dm755 "DecentSampler" "${pkgdir}/usr/bin/DecentSampler"
+ install -Dm755 "DecentSampler.so" "${pkgdir}/usr/lib/vst/DecentSampler.so"
+ install -d "${pkgdir}/usr/lib/vst3"
+ cp -r "DecentSampler.vst3" "${pkgdir}/usr/lib/vst3/"
+ cd "${srcdir}"
+ install -Dm755 "decent sampler.desktop" "${pkgdir}/usr/share/applications/decent-sampler.desktop"
+ install -Dm755 "decent sampler.png" "${pkgdir}/usr/share/pixmaps/decent-sampler.png"
+ install -Dm755 "application-decent-sampler.xml" "${pkgdir}/usr/share/mime/packages/application-decent-sampler.xml"
+}