summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhang, DingYuan2020-11-08 16:08:57 +0800
committerZhang, DingYuan2020-11-08 16:08:57 +0800
commitfe6b94d6eb8cc48491f482cb520ff465bc0c9543 (patch)
tree5a804b15f78762305106ef5f07410183fd11a203 /PKGBUILD
parent79303266deb4b4f7c148379ba184021c255ea880 (diff)
downloadaur-fe6b94d6eb8cc48491f482cb520ff465bc0c9543.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a640ef057706..b62553301483 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: DingYuan Zhang <justforlxz@gmail.com>
pkgname=deepin-file-manager-git
-pkgver=5.2.0.37.r0.ga6fde9dd4
+pkgver=5.2.0.73.r82.g455f649ad
pkgrel=1
pkgdesc='Deepin File Manager'
arch=('x86_64')
url="https://github.com/linuxdeepin/dde-file-manager"
license=('GPL3')
# startdde: for com.deepin.SessionManager
-depends=('deepin-anything' 'disomaster' 'file' 'gio-qt' 'libmediainfo' 'avfs' 'polkit-qt5' 'poppler'
+depends=('deepin-anything-git' 'disomaster' 'file' 'gio-qt' 'libmediainfo' 'avfs' 'polkit-qt5' 'poppler'
'ffmpegthumbnailer' 'startdde-git' 'taglib' 'jemalloc' 'htmlcxx' 'mimetic' 'lucene++')
makedepends=('git' 'lucene++' 'jemalloc' 'kcodecs' 'htmlcxx' 'libgsf' 'mimetic' 'boost' 'boost-libs' 'qt5-tools' 'deepin-dock-git' 'deepin-gettext-tools-git')
optdepends=('deepin-manual: for help menual'
@@ -20,11 +20,8 @@ optdepends=('deepin-manual: for help menual'
groups=('deepin-git')
provides=('deepin-file-manager')
conflicts=('deepin-file-manager')
-replaces=('deepin-file-manager')
-source=("$pkgname::git://github.com/linuxdeepin/dde-file-manager"
- "deepin-file-manager-qt5.15.patch")
-sha512sums=('SKIP'
- '0c38761b7a44dc581d7d4fedc2c51cf702769ec43a325384f13ce427cf2dccc8af4b59e82f4bd567449073926f4a7ad433147ea01db0ad8ab75eb46f7150a3eb')
+source=("$pkgname::git://github.com/linuxdeepin/dde-file-manager")
+sha512sums=('SKIP')
pkgver() {
cd $pkgname
@@ -32,10 +29,11 @@ pkgver() {
}
prepare() {
- cd ${pkgname}
- sed -i 's|systembusconf.path = /etc/dbus-1/system.d|systembusconf.path = /usr/share/dbus-1/system.d|' dde-file-manager-daemon/dde-file-manager-daemon.pro
-
- patch -p1 -i ../deepin-file-manager-qt5.15.patch # Fix build with Qt 5.15
+ cd ${pkgname}
+ sed -i '/#include <QException>/a #include <QPainterPath>' dialogs/dfmtaskwidget.cpp
+ sed -i '/#include <QTimer>/a #include <QPainterPath>' dde-file-manager-lib/interfaces/dfmglobal.cpp
+ sed -i '/#include <QPainter>/a #include <QPainterPath>' dde-file-manager-lib/interfaces/{dlistitemdelegate,dfmstyleditemdelegate,diconitemdelegate}.cpp dde-file-manager-lib/dialogs/openwithdialog.cpp
+ sed -i 's|systembusconf.path = /etc/dbus-1/system.d|systembusconf.path = /usr/share/dbus-1/system.d|' dde-file-manager-daemon/dde-file-manager-daemon.pro
}
build() {