summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjustforlxz2022-03-20 01:05:54 +0800
committerjustforlxz2022-03-20 01:05:54 +0800
commitf31c0fad73368e0b95614e75e5e0bf5433cf7a4f (patch)
tree9810e1bf5b3ac4b1a4bcb452599061f6c60ba7e7 /PKGBUILD
parent4ffc6206c288a98218f472a2370cab12d3431551 (diff)
downloadaur-f31c0fad73368e0b95614e75e5e0bf5433cf7a4f.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3c87bae97d3..c0da18a6edcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,11 @@ pkgrel=1
pkgdesc="Deepin GTK Theme"
arch=('any')
url="https://github.com/linuxdeepin/deepin-gtk-theme"
+makedepends=('git')
license=('LGPL3')
optdepends=('gtk-engine-murrine: for gtk2 themes')
groups=('deepin')
-source=("$pkgname::git://github.com/linuxdeepin/deepin-icon-theme/")
+source=("$pkgname::git+https://github.com/linuxdeepin/deepin-icon-theme/")
sha512sums=('SKIP')
pkgver() {
@@ -21,6 +22,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $pkgname
+ if [[ ! -z ${sha} ]];then
+ git checkout -b $sha
+ fi
+}
+
build() {
cd $pkgname
make hicolor-links