summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjustforlxz2024-01-10 21:17:36 +0800
committerjustforlxz2024-01-10 21:17:36 +0800
commit7ae41f7ea4df8b1db6a4ec1aea5816f7fcd5f13d (patch)
tree367efe62d66b70fcc8ca8ecdfc9d94f6f9cae219 /PKGBUILD
parent7cade029145277bcf324d005ec141a398a08f980 (diff)
downloadaur-7ae41f7ea4df8b1db6a4ec1aea5816f7fcd5f13d.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3454e55520a..f6264585109b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=deepin-qt5platform-plugins-git
-pkgver=5.0.46.r34.gf0126d8
+pkgver=5.6.20.r1.g859044f
pkgrel=1
pkgdesc='Qt platform plugins for DDE'
arch=('x86_64' 'aarch64')
@@ -9,7 +9,7 @@ url="https://github.com/linuxdeepin/qt5platform-plugins"
license=('GPL3')
provides=('deepin-qt5platform-plugins')
conflicts=('deepin-qt5platform-plugins')
-depends=('cairo' 'kwayland' 'qt5-wayland' 'qt5-x11extras')
+depends=('cairo' 'dwayland-git' 'qt5-wayland' 'qt5-x11extras')
makedepends=('git' 'expac' 'qt5-xcb-private-headers' 'libglvnd' 'libxcb')
groups=('deepin-git')
source=("$pkgname::git+https://github.com/linuxdeepin/qt5platform-plugins")
@@ -22,28 +22,21 @@ pkgver() {
prepare() {
cd $pkgname
- if [[ ! -z ${sha} ]];then
- git checkout -b $sha
- fi
-
rm -r xcb/libqt5xcbqpa-dev wayland/qtwayland-dev
- # Disable wayland for now: https://github.com/linuxdeepin/qt5platform-plugins/issues/47
- sed -i '/wayland/d' qt5platform-plugins.pro
-
- sed -i 's|error(Not support Qt Version: .*)|INCLUDEPATH += /usr/include/qtxcb-private|' xcb/linux.pri
- sed -i "/qtwayland-dev/a /usr/include/qt/QtWaylandClient/$(expac %v qt5-wayland | cut -d - -f 1) /usr/include/qt/QtXkbCommonSupport/$(expac %v qt5-base | cut -d - -f 1) \\\\" wayland/wayland.pro
-
- # https://github.com/linuxdeepin/qt5platform-plugins/pull/48
- sed -i 's/xcbWindow-/window-/' xcb/windoweventhook.cpp
+ sed -i '/find_package/i find_package(ECM REQUIRED 1.0.0)\nset(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${CMAKE_MODULE_PATH})' wayland/wayland-shell/wayland-shell.cmake
+ sed -i 's|qt${QT_VERSION_MAJOR}/plugins|qt/plugins|' xcb/CMakeLists.txt wayland/*/CMakeLists.txt
}
build() {
cd $pkgname
- qmake-qt5 PREFIX=/usr
- make
+ cmake . -GNinja \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT_XCB_PRIVATE_HEADERS=/usr/include/qtxcb-private
+ cmake --build .
}
package() {
cd $pkgname
- make INSTALL_ROOT="$pkgdir" install
+ DESTDIR="$pkgdir" ninja install
}