summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjustforlxz2024-01-21 20:23:58 +0800
committerjustforlxz2024-01-21 20:23:58 +0800
commit53adb6ab79d65b7b71c367beec8819b97da023c8 (patch)
tree5d2edffc64ec0032c057a13e659f2a37186f7229 /PKGBUILD
parent70ca6ff1ae30d7b460d3619c87e2437b21ed8497 (diff)
downloadaur-deepin-wallpapers-git.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8897bb128a9..907a692bbab9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,34 @@
# Contributor: Xu Fasheng <fasheng.xu[AT]gmail.com>
pkgname=deepin-wallpapers-git
-pkgver=1.8.3.r10.g548f259
+sourcename=deepin-wallpapers
+pkgver=1.7.16.r2.ga1bdfad
pkgrel=1
pkgdesc='Deepin Wallpapers'
arch=('any')
license=('GPL')
url="https://github.com/linuxdeepin/deepin-wallpapers"
-makedepends=('git' 'deepin-api-git')
+makedepends=('git' 'deepin-api')
groups=('deepin-git')
-source=("$pkgname::git+https://github.com/linuxdeepin/deepin-wallpapers/")
+source=("git+https://github.com/linuxdeepin/deepin-wallpapers/")
provides=('deepin-wallpapers')
conflicts=('deepin-wallpapers')
sha512sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd $sourcename
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $pkgname
+ cd $sourcename
for _pic in deepin/*; do
make PICS=$_pic
done
}
package() {
- cd $pkgname
+ cd $sourcename
install -dm755 "$pkgdir"/usr/share/wallpapers
cp -r deepin "$pkgdir"/usr/share/wallpapers/
install -dm755 "$pkgdir"/var/cache