summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjustforlxz2022-12-27 13:59:59 +0800
committerjustforlxz2022-12-27 13:59:59 +0800
commit44519cff2281ceb3962a428972e90e9a39e8a762 (patch)
tree9ecef9de586d81bf83b1550b38d41add29614b14 /PKGBUILD
downloadaur-44519cff2281ceb3962a428972e90e9a39e8a762.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ecb294c28f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: justforlxz <justforlxz@gmail.com>
+
+pkgname=deepin-wayland-protocols-git
+pkgver=1.6.0.deepin.1.2.r0.g193899b
+pkgrel=1
+pkgdesc='deepin Specific Protocols for Wayland'
+url="https://github.com/justforlxz/deepin-wayland-protocols"
+arch=(any)
+license=(LGPL)
+makedepends=(qt5-base extra-cmake-modules)
+source=("${pkgname}::git+https://github.com/linuxdeepin/deepin-wayland-protocols")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cmake -B build -S $pkgname
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+