aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCodist2021-06-21 15:17:53 +0800
committerCodist2021-06-21 15:19:21 +0800
commit910fabab55a7584bb3900b3329c4ca6e08490649 (patch)
tree0bb5020418836a2afc129f19eea973da0dc501f1 /PKGBUILD
parenta4be180dd33f1a5f52f07dd2cefe3c35c7585fd9 (diff)
downloadaur-910fabab55a7584bb3900b3329c4ca6e08490649.tar.gz
Upgrade WeChat to 3.3.0.93 and disable 'wechatbrowser.exe'
Signed-off-by: Codist <countstarlight@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b9f8d3a21ec..af1877f7cc65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Codist <countstarlight@gmail.com>
pkgname=deepin-wine-wechat
-pkgver=3.2.1.154
+pkgver=3.3.0.93
wechat_installer=WeChatSetup
deepinwechatver=3.2.1.154deepin8
debpkgname="com.qq.weixin.deepin"
-pkgrel=2
+pkgrel=1
pkgdesc="Tencent WeChat on Deepin Wine(${debpkgname}) For Archlinux"
arch=("x86_64")
url="https://weixin.qq.com/"
@@ -16,10 +16,12 @@ install="deepin-wine-wechat.install"
_mirror="https://cdn-package-store6.deepin.com"
source=("$_mirror/appstore/pool/appstore/c/${debpkgname}/${debpkgname}_${deepinwechatver}_i386.deb"
"${wechat_installer}-${pkgver}.exe::https://dldir1.qq.com/weixin/Windows/${wechat_installer}.exe"
- "run.sh")
+ "run.sh"
+ "reg.patch")
md5sums=('3246f43cdfd2a4de9597d7018cb21753'
- 'ea0a150ac98d022e9c6054154f27ddb4'
- 'f4e982842a71462126350360a01b9e94')
+ 'b910c29a00a44b5b8a40c8d158f4dca6'
+ '18349448422572dd9a784eb5c6367c6c'
+ 'f3257f8fc9e73ea88b3a46372634f82f')
build() {
msg "Extracting DPKG package ..."
@@ -32,6 +34,8 @@ build() {
7z x -aoa "${srcdir}/dpkgdir/opt/apps/${debpkgname}/files/files.7z" -o"${srcdir}/deepinwechatdir"
msg "Cleaning up the original package directory ..."
rm -r "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/WeChat"
+ msg "Patching reg files ..."
+ patch -p1 -d "${srcdir}/deepinwechatdir/" < "${srcdir}/reg.patch"
msg "Creating font file link ..."
ln -sf "/usr/share/fonts/wenquanyi/wqy-microhei/wqy-microhei.ttc" "${srcdir}/deepinwechatdir/drive_c/windows/Fonts/wqy-microhei.ttc"
msg "Copying latest WeChat installer to ${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/ ..."