aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCodist2020-11-21 19:25:11 +0800
committerCodist2020-11-21 19:25:11 +0800
commitedd35c34c276b46e111f6bb8e18073c5dc824cba (patch)
tree73b0c0363161cb62053f21e7bd550612a30d37a1 /PKGBUILD
parentd5d1521aaa4adfdd4b27bafb03180acc4554f4e1 (diff)
downloadaur-edd35c34c276b46e111f6bb8e18073c5dc824cba.tar.gz
set the deepin package mirror to 'http://packages.deepin.com'
Signed-off-by: Codist <countstarlight@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 080be50080b4..055d061f67e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ license=('custom')
depends=('p7zip' 'wine' 'wine-mono' 'wine-gecko' 'xorg-xwininfo' 'wqy-microhei' 'lib32-alsa-lib' 'lib32-alsa-plugins' 'lib32-libpulse' 'lib32-openal' 'lib32-mpg123' 'lib32-libldap')
conflicts=('deepin-wechat')
install="deepin-wine-wechat.install"
-_mirror="https://ftp.sjtu.edu.cn/deepin"
+_mirror="http://packages.deepin.com/deepin"
source=("$_mirror/pool/non-free/d/deepin.com.wechat/deepin.com.wechat_${deepinwechatver}_i386.deb"
"${wechat_installer}-${pkgver}.exe::https://dldir1.qq.com/weixin/Windows/${wechat_installer}.exe"
"run.sh"
@@ -32,8 +32,9 @@ build() {
sed "13s/WeChat.exe/wechat.exe/" -i "${srcdir}/dpkgdir/usr/share/applications/deepin.com.wechat.desktop"
msg "Extracting Deepin Wine WeChat archive ..."
7z x -aoa "${srcdir}/dpkgdir/opt/deepinwine/apps/Deepin-WeChat/files.7z" -o"${srcdir}/deepinwechatdir"
- msg "Removing original outdated WeChat directory ..."
+ msg "Cleaning up the original package directory ..."
rm -r "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/WeChat"
+ find -L "${srcdir}/deepinwechatdir/dosdevices" -maxdepth 1 -type l -delete
msg "Patching reg files ..."
patch -p1 -d "${srcdir}/deepinwechatdir/" < "${srcdir}/reg.patch"
msg "Adding shadow.exe..."