summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-17 08:37:36 +0300
committerDimitris Kiziridis2020-07-17 08:37:36 +0300
commit7877961b89dd608e73c08f9da817a63ba1f82df8 (patch)
treefc0bae566a94d2c76c1749bba92451cba920d96d /PKGBUILD
parentb1b47d47c56901fda561be1693690a778a96c5f7 (diff)
downloadaur-deepnest-bin.tar.gz
restructure package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61bd2c43b32f..207c32ff7197 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,18 +7,24 @@ pkgdesc='An open source nesting application, great for laser cutters, plasma cut
arch=('x86_64')
url='https://deepnest.io'
license=('custom:unknown')
-install=deepnest.install
-depends=('zlib' 'pango-legacy' 'bash')
+depends=('pango-legacy')
provides=('deepnest')
-options=('!strip')
-source=("${pkgname}-${pkgver}.zip::https://deepnest.io/Deepnest-${pkgver}-linux.zip")
+source=("${pkgname%-bin}-${pkgver}.zip::https://deepnest.io/Deepnest-${pkgver}-linux.zip")
sha256sums=('54c049da97acc39741a4c960833258b0b2f9772dbdffdc1a27370983a8657a51')
package() {
- install -d "${pkgdir}/opt/${pkgname%-bin}"
- install -Dm755 "${srcdir}/Deepnest-${pkgver}-linux/Deepnest-${pkgver}-x86_64.AppImage" -t "${pkgdir}/opt/${pkgname%-bin}/"
+ cd Deepnest-${pkgver}-linux/
+ chmod 755 ./Deepnest-${pkgver}-x86_64.AppImage
+ ./Deepnest-${pkgver}-x86_64.AppImage --appimage-extract
echo "#!/usr/bin/env bash
- LD_LIBRARY_PATH=/opt/pango-legacy/usr/lib /opt/deepnest/Deepnest-${pkgver}-x86_64.AppImage" > deepnest
+ LD_LIBRARY_PATH=/opt/pango-legacy/usr/lib /opt/deepnest/AppRun" > deepnest
install -Dm755 deepnest -t "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/opt"
+ install -Dm644 squashfs-root/usr/share/icons/hicolor/512x512/apps/deepnest.png -t "${pkgdir}/usr/share/pixmaps"
+ sed -i "4s|AppRun|deepnest|" squashfs-root/deepnest.desktop
+ install -Dm644 squashfs-root/deepnest.desktop -t "${pkgdir}/usr/share/applications"
+ cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname%-bin}"
+ find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} +
+ find "${pkgdir}/opt/${pkgname%-bin}/usr/share/icons" -type f -exec chmod 644 {} +
}
# vim:set ts=2 sw=2 et: \ No newline at end of file