summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2020-05-23 15:31:45 +0200
committerMichel Zou2020-05-23 15:31:45 +0200
commit4824357570105087964e0d5c632fb69651f9f450 (patch)
treef60b35a1475ba9d6f4ef09dea7338cee487b623e /PKGBUILD
parentb6636f70e801676af726aa752c8df8579189d31a (diff)
downloadaur-4824357570105087964e0d5c632fb69651f9f450.tar.gz
ctcdecode
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d93e6e7372a..f4bd62afb85d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,6 +37,7 @@ build() {
cd "${srcdir}/${_pkgname}-${pkgver//_/-}/native_client"
make deepspeech SOX_LDFLAGS="-lsox -Wl,-no-undefined"
make bindings -C python
+ make bindings -C ctcdecode
}
package_deepspeech() {
@@ -50,5 +51,7 @@ package_python-deepspeech() {
depends=('deepspeech' 'python-numpy')
cd "${srcdir}/${_pkgname}-${pkgver//_/-}/native_client"
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps python/dist/deepspeech*.whl
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ctcdecode/dist/ds_ctcdecoder*.whl
mv "$pkgdir/usr/bin/deepspeech" "$pkgdir/usr/bin/deepspeech_python"
+ cp -rv "${srcdir}/${_pkgname}-${pkgver//_/-}/training/deepspeech_training" "$pkgdir"`python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())"`
}