summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2020-08-24 12:19:50 +0200
committerMichel Zou2020-08-24 12:19:50 +0200
commitf13d7c98d8fe9251824297a28fcba61d44d201f0 (patch)
tree86ebd44ce0cd4dcb5baa4a6c377dec408badde56 /PKGBUILD
parent604d246bcd1c981714624251f38ba61920eee9a0 (diff)
downloadaur-f13d7c98d8fe9251824297a28fcba61d44d201f0.tar.gz
0.8.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5fb135440e01..b3dfa568bd27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
pkgbase=deepspeech
pkgname=('deepspeech' 'python-deepspeech')
_pkgname=DeepSpeech
-pkgver=0.7.4
+pkgver=0.8.2
pkgrel=1
pkgdesc="A TensorFlow implementation of Baidu's DeepSpeech architecture"
arch=('x86_64')
url="https://github.com/mozilla/DeepSpeech"
license=('MPL2')
-makedepends=('bazel=0.24.1' 'python-numpy' 'python-pip' 'python-wheel' 'git' 'sox')
+makedepends=('bazel=2.0.0' 'python-numpy' 'python-pip' 'python-wheel' 'git' 'sox')
source=("${_pkgname}-${pkgver}::git+https://github.com/mozilla/DeepSpeech.git#tag=v${pkgver//_/-}"
- "git+https://github.com/mozilla/tensorflow.git#branch=r1.15")
+ "git+https://github.com/mozilla/tensorflow.git#branch=r2.2")
sha256sums=('SKIP' 'SKIP')
prepare()
@@ -30,6 +30,7 @@ build() {
export TF_DOWNLOAD_CLANG=0
export TF_NEED_CUDA=0
export CC_OPT_FLAGS="-march=x86-64"
+ rm .bazelversion
./configure
bazel build --workspace_status_command="bash native_client/bazel_workspace_status_cmd.sh" --config=monolithic -c opt --copt=-O3 --copt="-D_GLIBCXX_USE_CXX11_ABI=0" --copt=-fvisibility=hidden //native_client:libdeepspeech.so