summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Heinrich2018-03-27 19:24:12 +0200
committerJonas Heinrich2018-03-27 19:24:12 +0200
commit5ca133b21f806eb0e12d27830f400056e9c83aaa (patch)
tree24d3821e8bbc4ffb6617ce7d90b30e429341b189 /PKGBUILD
parent1b638bc798d7b6a0c4f5432b8fbf642d3f67bfe4 (diff)
downloadaur-5ca133b21f806eb0e12d27830f400056e9c83aaa.tar.gz
update build instructions according to upstream docu
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7efad80e538e..cf4091291626 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=deepspeech-git
_pkgname=DeepSpeech
pkgver=0.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A TensorFlow implementation of Baidu's DeepSpeech architecture"
arch=('x86_64')
url="https://github.com/mozilla/DeepSpeech"
@@ -12,7 +12,7 @@ license=('MPL2')
makedepends=('bazel' 'python-numpy' 'python-pip' 'python-wheel' 'python-setuptools')
depends=('python-tensorflow' 'python-scipy')
source=("git+https://github.com/mozilla/DeepSpeech.git"
- "git+https://github.com/tensorflow/tensorflow.git")
+ "git+https://github.com/mozilla/tensorflow.git")
sha512sums=('SKIP'
'SKIP')
@@ -27,6 +27,8 @@ prepare() {
export PYTHON_BIN_PATH=/usr/bin/python
export USE_DEFAULT_PYTHON_LIB_PATH=1
export TF_NEED_JEMALLOC=1
+ export TF_NEED_KAFKA=0
+ export TF_NEED_OPENCL_SYCL=0
export TF_NEED_GCP=0
export TF_NEED_HDFS=0
export TF_NEED_S3=0
@@ -35,15 +37,20 @@ prepare() {
export TF_NEED_VERBS=0
export TF_NEED_OPENCL=0
export TF_NEED_MPI=0
- ln -sf ../DeepSpeech-${pkgver}/native_client ./
+ export TF_NEED_TENSORRT=0
+ export TF_SET_ANDROID_WORKSPACE=0
+ export TF_DOWNLOAD_CLANG=0
+ ln -sf ../DeepSpeech/native_client ./
}
build() {
cd "$srcdir/tensorflow"
- export CC_OPT_FLAGS="-march=x86-64"
+
+ export CC_OPT_FLAGS="-march=native"
export TF_NEED_CUDA=0
./configure
- bazel build -c opt --copt=-O3 //tensorflow:libtensorflow_cc.so //tensorflow:libtensorflow_framework.so //native_client:deepspeech //native_client:deepspeech_utils //native_client:ctc_decoder_with_kenlm //native_client:generate_trie
+ bazel build -c opt --copt=-O3 //native_client:libctc_decoder_with_kenlm.so
+ bazel build --config=monolithic -c opt --copt=-O3 --copt=-fvisibility=hidden //native_client:libdeepspeech.so //native_client:deepspeech_utils //native_client:generate_trie
cd "${srcdir}/DeepSpeech-${pkgver}/native_client"
make deepspeech