summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSlashbunny2021-03-28 10:14:16 -0400
committerSlashbunny2021-03-28 10:14:16 -0400
commitd2e8a9bc44f1cdd1b294a46213d9479fae3f96bf (patch)
tree7a2cb1ae3e8675a731802ca92dd3b5cf17304141 /PKGBUILD
parent06b815c07d78d4eb7973cf7ec856c1bf41512cde (diff)
downloadaur-d2e8a9bc44f1cdd1b294a46213d9479fae3f96bf.tar.gz
Modernize PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a84f1c180fb2..a8e789b5824e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
pkgname=defrag
pkgver=0.08
pkgrel=1
-pkgdesc="A braindead simple and filesystem agnostic defrag script"
+pkgdesc="A braindead simple and filesystem agnostic defragmentation script"
url="http://ck.kolivas.org/apps/defrag/"
license=()
depends=('bash')
-arch=('i686' 'x86_64')
-source=(http://ck.kolivas.org/apps/defrag/$pkgname-$pkgver/defrag)
-md5sums=('cdc2179f521689356834efaedad15a62')
+arch=('any')
+source=("http://ck.kolivas.org/apps/defrag/$pkgname-$pkgver/defrag")
+sha512sums=('fa1c9c3a58ec43020a6a1da66bcbf8304e9b2ad1afbd25c0aab0962410e977412954669be2ae2aaaf8b14b2294cad91bbb0143f589688aa684080dff1b2c5316')
-build() {
- cd $srcdir
+package() {
+ cd "${srcdir}"
- install -D -m755 defrag $pkgdir/usr/bin/defrag
+ install -D -m755 defrag "${pkgdir}/usr/bin/defrag"
}
+