summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-04 01:02:29 +0300
committerCaleb Maclennan2023-05-04 01:02:29 +0300
commit2a84b3057fa95537693b3418be76849e63bf3197 (patch)
treec783b6aee4822b544bdfe39cb4cf2d3acb3d2b51 /PKGBUILD
parent933b71dfeb67f80255c595ecb21f00c26212f472 (diff)
downloadaur-2a84b3057fa95537693b3418be76849e63bf3197.tar.gz
upgpkg: dehinter 4.0.0-3
Rebuild for Python 3.11, normalize PEP517 build tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe933ee79bb6..9a204c3bfe27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,25 @@
pkgname=dehinter
pkgver=4.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='A tool for the removal of TrueType instruction sets (hints) in fonts'
arch=(any)
url="https://github.com/source-foundry/$pkgname"
license=(MIT)
depends=(python
python-fonttools)
-makedepends=(python-setuptools-scm)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools-scm)
_archive="$pkgname-$pkgver"
source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('c7fd270fdd6d1b67326c1af61a3497eb86974567aff7e96ebee836d81fa56769')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}