summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-26 23:12:12 +0200
committerMarcell Meszaros2022-06-26 23:12:29 +0200
commit45b82fc42aec56d0c4afef4e9b53af1017003b50 (patch)
tree6e24886937caad60980e43b5b47b69add011170b /PKGBUILD
parent60c94726dccd32c62cfbf1ca9be6fe9fc5ba5cdf (diff)
downloadaur-45b82fc42aec56d0c4afef4e9b53af1017003b50.tar.gz
bump 1.3.15-10: disable make-time dependence on libtorrent-rasterbar
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c186e69572c8..b3d449fe00ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname='deluge1'
_basename="${pkgname%1}"
pkgver=1.3.15
-pkgrel=9
+pkgrel=10
pkgdesc='BitTorrent client with multiple interfaces, using a client/server model (legacy 1.3.x version)'
arch=('any')
url='https://deluge-torrent.org/'
@@ -15,12 +15,11 @@ depends=(
)
makedepends=(
'intltool'
- 'libtorrent-rasterbar<=1:1.2.10-4'
'python2-setuptools'
)
optdepends=(
- 'python2-geoip: for peer IP geolocation'
'libtorrent-rasterbar<=1:1.2.10-4: for the daemon'
+ 'python2-geoip: for peer IP geolocation'
'python2-notify: notifications for GTK client'
'python2-pygame: audible notifications for GTK client'
'python2-libappindicator: appindicator notifications for GTK client'
@@ -63,6 +62,10 @@ prepare() {
-e '1s|#![ ]*/usr/bin/env python[^2]\?|#!/usr/bin/env python2|' \
-e '1s|#![ ]*/bin/env python[^2]\?|#!/usr/bin/env python2|' \
-i $(find . -name '*.py')
+
+ echo "Disabling 'get_libtorrent.sh': don't try to download libtorrent from SVN"
+ sed -e '5s|^$|exit 127|' \
+ -i 'get_libtorrent.sh'
}
build() {