summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Tatschner2020-10-07 15:58:00 +0200
committerStefan Tatschner2020-10-07 15:58:00 +0200
commit737cf795fe6915a67e978f0366d8e8a09d93872e (patch)
treededc6ed9252456c033617cc3867a73b1a6be07e9 /PKGBUILD
downloadaur-737cf795fe6915a67e978f0366d8e8a09d93872e.tar.gz
Initial upload: dendrite 0.1.0rc2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65f17fc1fc8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Stefan Tatschner <stefan@rumpelsepp.org>
+
+pkgname=dendrite
+pkgver=0.1.0rc2
+pkgrel=1
+pkgdesc="A second-generation Matrix homeserver written in Go"
+arch=('x86_64')
+url='https://github.com/matrix-org/dendrite'
+license=('Apache')
+makedepends=('go')
+source=("git+https://github.com/matrix-org/dendrite.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
+ go build ./cmd/dendrite-monolith-server
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 dendrite-monolith-server "${pkgdir}/usr/bin/dendrite"
+}