summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLionel Miller2018-07-15 09:53:55 +0300
committerLionel Miller2018-07-15 09:54:50 +0300
commit58a44d3c770dfce97027f39bcb7805822e70765c (patch)
treec3ab6a7aa8cd1e9d0e021b2f0e272623db6ee74c /PKGBUILD
parentc1ad83d3edcff04e64246ba4f093d6d35b48346a (diff)
downloadaur-dendrix.tar.gz
Address review suggestions
https://www.reddit.com/r/archlinux/comments/8yt8uo/pkgbuild_review_request/
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5f7ade17238..773fdd399144 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,12 @@
pkgname=dendrix
pkgver=0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Algorithm for discovery of mutated driver pathways in cancer using only mutation data"
arch=('any')
url="http://compbio.cs.brown.edu/projects/dendrix/"
-license=('MIT')
+license=('custom')
depends=('python2')
-provides=('dendrix')
source=("$pkgname-$pkgver.zip::http://compbio-research.cs.brown.edu/software/Dendrix/Dendrix_v$pkgver.zip")
sha512sums=('39fd7983b34c25b5e69ed230d9f4da2795fb64057c9891afa136953855391cd8d019ac5cdfc28b69a931852b8dca381ebd01bf93c3cd7c53ab7b36f967479f7b')
@@ -16,15 +15,22 @@ prepare() {
cd Dendrix
sed -e "s:#!/usr/bin/env python:#!/usr/bin/env python2:" \
+ -e "s:README.txt:/usr/share/doc/$pkgname/README.txt:" \
-i Dendrix.py -i PermutationTestDendrix.py
+ sed -e "s/python Dendrix.py/dendrix/" -i Dendrix.py
+ sed -e "s/python permutationTestDendrix.py/permutation_test_dendrix/" -i PermutationTestDendrix.py
}
package() {
cd Dendrix
- install -Dm755 Dendrix.py "$pkgdir/usr/bin/Dendrix.py"
- install -Dm755 PermutationTestDendrix.py "$pkgdir/usr/bin/PermutationTestDendrix.py"
+ install -Dm755 Dendrix.py "$pkgdir/usr/bin/dendrix"
+ install -Dm755 PermutationTestDendrix.py "$pkgdir/usr/bin/permutation_test_dendrix"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -d "$pkgdir/usr/share/$pkgname/"
- cp -r README.txt RELEASE_NOTES.txt example/ "$pkgdir/usr/share/$pkgname/"
+
+ mkdir -p "$pkgdir/usr/share/$pkgname/"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname/"
+
+ cp README.txt RELEASE_NOTES.txt "$pkgdir/usr/share/doc/$pkgname/"
+ cp -r example/ "$pkgdir/usr/share/$pkgname/"
}