summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom X. Tobin2017-09-19 08:02:12 -0400
committerTom X. Tobin2017-09-19 08:02:12 -0400
commit43ed7c3b11e87bf54289a628469e991551a27c19 (patch)
treeb5e5abde6de938d491fb9ad1091ae76201672a27 /PKGBUILD
parent136e62e6d99432ef34e553c8372c68b94eb03c3f (diff)
downloadaur-43ed7c3b11e87bf54289a628469e991551a27c19.tar.gz
Update to dep 0.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 163d7664337e..37fbd8afd5dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tom X. Tobin <tomxtobin@tomxtobin.com>
pkgname=dep
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="Go dependency management tool"
arch=('i686' 'x86_64')
@@ -11,7 +11,14 @@ license=('BSD')
makedepends=('go')
options=('!emptydirs' '!strip')
source=("https://${_vendor}/archive/v${pkgver}.tar.gz")
-sha256sums=('7d816ffb14f57c4b01352676998a8cda9e4fb24eaec92bd79526e1045c5a0c83')
+sha256sums=('386e2d163c5a95166fa3b89da4f8166361c7c5210fb172f64c116cccd19d1d44')
+_git_commit='83789e236d7ff64c82ee8392005455fc1ec1983b'
+_ldflags="\
+-s \
+-w \
+-X main.buildDate=$(date --iso-8601) \
+-X main.commitHash=$_git_commit \
+-X main.version=v$pkgver"
_vendorpath="gopath/src/$_vendor"
_buildpath="$_vendorpath/cmd/dep"
@@ -24,7 +31,7 @@ prepare() {
build() {
export GOPATH="$srcdir/gopath"
cd $_buildpath
- go build -o bin/$pkgname
+ go build -ldflags "$_ldflags" -o bin/$pkgname
}
package() {