summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean-Luc2016-12-25 18:47:54 +1100
committerJean-Luc2016-12-25 18:47:54 +1100
commit794c7841218e397840a1f8db0c14781104549e80 (patch)
tree0fb08b4bacc10ba7b9f1ade5dd906cc83aac2908 /PKGBUILD
downloadaur-794c7841218e397840a1f8db0c14781104549e80.tar.gz
Added package files.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..588703782d4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jean-Luc Tambasco <an.obscurity@gmail.com>
+
+pkgname=descartes
+pkgver=1.6
+pkgrel=1
+pkgdesc="Use Shapely or GeoJSON-like geometric objects as matplotlib paths and patches."
+arch=('x86_64')
+url="https://github.com/Toblerity/Shapely"
+groups=('descartes')
+depends=('python2-shapely')
+source=('hg+https://bitbucket.org/sgillies/descartes')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/${pkgname}"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ python2 setup.py install --user
+}