summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2020-02-04 23:59:43 +0100
committerRicardo (XenGi) Band2020-02-04 23:59:43 +0100
commitbc469b456c5a6db7547e8b1dfe0d745a62adacfd (patch)
tree9c538be916bc10f36af92162beb82127c35114bf /PKGBUILD
downloadaur-bc469b456c5a6db7547e8b1dfe0d745a62adacfd.tar.gz
dump first try
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10ffd2cd34a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ricardo Band <email@ricardo.band>
+pkgname=desec-dns-cli
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="CLI tool for the desec.io DNS service"
+arch=("any")
+url=https://gitlab.com/XenGi/desec-dns-cli
+license=("MIT")
+depends=("python>=3.6" "python-click" "python-requests")
+makedepends=("python-setuptools")
+checkdepends=("python-pytest" "python-pytest-xdist" "python-responses")
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=("ed6ecd486f13a707ce19baffd964392ba1a086052c682cc518cb34dd4a5c5ebb")
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ #pytest tests/
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+