summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPetr Šťastný2020-04-21 23:26:02 +0200
committerPetr Šťastný2020-04-21 23:27:33 +0200
commit27db31b14b290ad7b300f20742865fff67f93892 (patch)
treeebec3a46b77df30906920ac1818db4a6b29c4632 /PKGBUILD
downloadaur-27db31b14b290ad7b300f20742865fff67f93892.tar.gz
Added first version of desed package.
This package, unlike it's -git counterpart, builds the latest release, instead of latest commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d9528428601
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Petr Šťastný <aur@soptik.tech>
+pkgname=desed
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Debugger for sed, written in rust. Step through code and observe sed inner state."
+arch=('x86_64')
+url="https://github.com/soptikha2/desed"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('cargo' 'git')
+conflicts=('desed')
+source=("$pkgname::git+https://github.com/soptikha2/desed.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+
+ # Checkout to published version
+ git checkout 'tags/v1.1.1'
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+
+ install -D "target/release/desed" -t "$pkgdir/usr/bin"
+}