summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-12-20 15:06:28 +0800
committerzxp198210052023-12-20 15:06:28 +0800
commitf12ecd3b4265cd0aa65e5a126a85a5c8c83e3e82 (patch)
treea3b51584a06700066270b5aaede667b1f71f1583 /PKGBUILD
parent263ef7d14695eee3e897f1040e78acfdcaddba66 (diff)
downloadaur-f12ecd3b4265cd0aa65e5a126a85a5c8c83e3e82.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3827f11cccd3..2ac6d367ff9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
pkgname=deskcal-bin
_appname=Deskcal
pkgver=1.0.6
+_electronversion=20
pkgrel=6
pkgdesc="An unofficial cross-platform desktop Google Calendar application."
arch=('x86_64')
@@ -10,7 +11,7 @@ license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'electron18'
+ "electron${_electronversion}"
)
makedepends=(
'gendesk'
@@ -20,8 +21,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('ab340f34a05895da69c61e1462b4b7d422e79b219633ed41f4e7d1a7ddf67d6a'
- '8b86d12f9e2ab842a6137ab9a2949a2067ff748d70ae0c9d0cdccb863e73426f')
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
gendesk -q -f -n --categories "Utility" --name "Google ${_appname}" --exec "${pkgname%-bin}"
}
package() {