summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2018-10-23 20:09:57 +0000
committerDavid Runge2018-10-23 20:09:57 +0000
commita376413881651829273c38c9a12cecf7347de23d (patch)
treec26d678191b23bb0f88b6e82ddc2532662556676 /PKGBUILD
downloadaur-a376413881651829273c38c9a12cecf7347de23d.tar.gz
Adding deteriorate-lv2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27a46b9400ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: David Runge <dave@sleepmap.de>
+pkgname=deteriorate-lv2
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="A set of plugins to deteriorate the sound quality of a live input"
+arch=('x86_64')
+url="https://objectivewave.wordpress.com/deteriorate-lv2/"
+license=('GPL3')
+groups=('lv2-plugins' 'pro-audio')
+depends=('gtkmm')
+makedepends=('lv2' 'lvtk' 'python2')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/blablack/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('81580c47ee8ed6d730a87f36b35646c9')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python2 ./waf configure --prefix=/usr
+ python2 ./waf
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python2 waf install --destdir="$pkgdir/"
+ install -vDm 644 {THANKS,README.md} -t "${pkgdir}/usr/share/doc/${pkgname}"
+}