summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRamon Snir2015-06-14 09:53:53 +0300
committerRamon Snir2015-06-14 09:53:53 +0300
commit0464445c43619c0291f5e3886c2fd11b7979e730 (patch)
treef73b25034d7bffea8052c5354c0440e8a39ac8b9 /PKGBUILD
downloadaur-0464445c43619c0291f5e3886c2fd11b7979e730.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7432f8df6d5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ramon Snir <r@mon.co.il>
+pkgname=detoul
+pkgver=0.1.3
+pkgrel=1
+epoch=
+pkgdesc="a declarative tool for creating integration branches in git"
+arch=('any')
+url="https://github.com/ramonsnir/detoul"
+license=('MIT')
+groups=()
+depends=('git>=2' 'grep>=2.19' 'perl>=5.18' 'sed' 'coreutils')
+optdepends=('bash-completion: for auto-completion in bash')
+provides=('git-pwd')
+source=("https://github.com/ramonsnir/detoul/archive/v$pkgver.tar.gz")
+md5sums=('75dbe95906450083ce63461a7f1cfd9a')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 bash-completion/detoul "${pkgdir}/usr/share/bash-completion/completions/detoul"
+ mkdir -p "${pkgdir}/opt/detoul/"
+ cp -R . "${pkgdir}/opt/detoul/"
+ mkdir -p "${pkgdir}/usr/bin"
+ cd "${pkgdir}/usr/bin"
+ ln -s /opt/detoul/detoul
+ ln -s /opt/detoul/git-pwd
+}