summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormusiclover2022-01-28 17:49:16 +0100
committermusiclover2022-01-28 17:49:16 +0100
commit8387d667d15728345b763e117c50886c5d99c428 (patch)
tree85d3f58356ec7f24f6c831fc9998a7f905224d8c /PKGBUILD
parentc0834ca27e860e307d7a4e50e1534cd0dd08fe4e (diff)
downloadaur-8387d667d15728345b763e117c50886c5d99c428.tar.gz
Fix meson fails to build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 269a1474262d..99be66f81562 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=detwinner
pkgver=0.4.1
-pkgrel=1
+pkgrel=2
pkgdesc='Duplicate file finder for the Linux desktop'
url='https://neatdecisions.com/products/detwinner-linux/'
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -10,11 +10,16 @@ license=('GPL3')
depends=('gtkmm3>=3.22' 'graphicsmagick')
makedepends=('meson' 'gtest' 'cppcheck')
checkdepends=('appstream-glib')
-source=("https://github.com/neatdecisions/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+source=("https://github.com/neatdecisions/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('08e348dff6ac40cec5f6bf3bd1ab4d7fbcde0932550a682d3171b5c1c34f7ffe')
+prepare() {
+ # Fix meson build removing positional arguments from i18n.merge_file
+ sed -i -e 's/\x27desktop\x27,//g' -e 's/\x27appdata\x27,//g' $pkgname-$pkgver/data/meson.build
+}
+
build() {
- arch-meson ${pkgname}-${pkgver} build
+ arch-meson $pkgname-$pkgver build
meson compile -C build
}
@@ -23,5 +28,5 @@ check() {
}
package() {
- meson install -C build --destdir "${pkgdir}"
+ meson install -C build --destdir "$pkgdir"
}