summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormusiclover2021-11-29 15:27:45 +0100
committermusiclover2021-11-29 15:27:45 +0100
commitc0834ca27e860e307d7a4e50e1534cd0dd08fe4e (patch)
treedf64a20bb027419d2bc481159954f7aae50f475e /PKGBUILD
downloadaur-c0834ca27e860e307d7a4e50e1534cd0dd08fe4e.tar.gz
Initial import: 0.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..269a1474262d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: musiclover <musiclover382@protonmail.com>
+
+pkgname=detwinner
+pkgver=0.4.1
+pkgrel=1
+pkgdesc='Duplicate file finder for the Linux desktop'
+url='https://neatdecisions.com/products/detwinner-linux/'
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+license=('GPL3')
+depends=('gtkmm3>=3.22' 'graphicsmagick')
+makedepends=('meson' 'gtest' 'cppcheck')
+checkdepends=('appstream-glib')
+source=("https://github.com/neatdecisions/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('08e348dff6ac40cec5f6bf3bd1ab4d7fbcde0932550a682d3171b5c1c34f7ffe')
+
+build() {
+ arch-meson ${pkgname}-${pkgver} build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir "${pkgdir}"
+}