summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRadim Sückr2020-06-19 10:10:53 +0200
committerRadim Sückr2020-06-19 10:10:53 +0200
commit21dd8bc7569b24f9d1490c1d2d755d96405684c9 (patch)
tree24fcf781b286bff6f516d9e46f348a3e8daaa521 /PKGBUILD
parente9416d1c79c833f9eaf467c927b1a11014a9db7e (diff)
downloadaur-21dd8bc7569b24f9d1490c1d2d755d96405684c9.tar.gz
Update to 0.0.37
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 23 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 222d822a1d10..5a6289885d1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,38 @@
# Maintainer: Radim Sückr <contact@radimsuckr.cz>
pkgname=developers-chamber
-pkgver=0.0.26
+pkgver=0.0.37
pkgrel=1
pkgdesc='Python developers utility library'
arch=('any')
url='https://github.com/druids/developers-chamber'
license=('MIT')
-depends=('python' 'python-boto3' 'python-docker' 'python-click' 'python-gitpython' 'python-requests' 'python-click-completion' 'python-hosts' 'python-coloredlogs' 'python-dotenv' 'python-isort' 'python-jira' 'python-unidecode' 'python-attrdict' 'python-togglpy')
+depends=(
+ 'python'
+ 'python-attrdict'
+ 'python-boto3'
+ 'python-click'
+ 'python-click-completion'
+ 'python-coloredlogs'
+ 'python-docker'
+ 'python-dotenv'
+ 'python-gitpython'
+ 'python-hosts'
+ 'python-isort'
+ 'python-jira'
+ 'python-oauthlib'
+ 'python-requests'
+ 'python-togglpy'
+ 'python-unidecode'
+)
makedepends=('python-setuptools')
-source=('git+https://github.com/druids/developers-chamber.git')
-sha512sums=('SKIP')
+source=('git+https://github.com/druids/developers-chamber.git' 'setup.patch')
+sha512sums=('SKIP'
+ 'd5f5879d6a23c7dfc15e9a0736936b211d052f20a5cc3aa88dc88d75007c93844dced7b1b4a051a11b8c347cf6aa8a5656a01e2c79ab3df15e243f5032df0fcf')
prepare() {
cd ${pkgname}
+ patch --forward --strip=1 --input="${srcdir}/setup.patch"
python setup.py build
}